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Creating HTML forms
This section describes how to create HTML forms in Dreamweaver.

You can also use Dreamweaver to create ASP.NET web forms. For more information, see Building ASP.NET forms.

To create an HTML form:

1. Open a page and place the insertion point where you want the form to appear. 
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NOTE Passwords and other information sent to a server using a password field are not encrypted. The
transferred data can be intercepted and read as slphanumeric text. For this reason, you should
always provide encryption for data you want to keep secure.

Hidden fields stors information entered by a user, such as a name, e-mail address, or viewing
preference, and then use that data when the user next visits the site

Buttons perform actions when dlicked. Typically these actions include submitting or resetting a
You can add a custom name or label for a button, or use one of the predefined "Submit" or "Reset’
labels

Checkboxes sllow multipls responses within a single aroup of options. A user can select as many.
options a5 apply. The example below ilustrates this by showing three checkbox items selected: Surfing,
Mountain Biking, and Rafting.
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NOTE Passwords and other information sent to a server using a password field are not encrypted. The
transferred data can be intercepted and read as slphanumeric text. For this reason, you should
always provide encryption for data you want to keep secure.

Hidden fields stors information entered by a user, such as a name, e-mail address, or viewing
preference, and then use that data when the user next visits the site

Buttons perform actions when dlicked. Typically these actions include submitting or resetting a
You can add a custom name or label for 3 button, or use one of the predsfined "Submit” or "Res:
labels

Checkboxes sllow multipls responses within a single aroup of options. A user can select as many.
options a5 apply. The example below ilustrates this by showing three checkbox items selected: Surfing,
Mountain Biking, and Rafting.
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Select Insert > Form, or select the Forms category in the Insert bar and click the Form icon. 
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Dreamweaver inserts an empty form. With a page in Design view, forms are indicated by a dotted red outline. If you don’t see this outline, check that View > Visual Aids > Invisible Elements is selected.

Red lines in Design view define the beginning and end of the form element, and <form> and </form> tags in Code view do the same thing. Stay inside the form element when adding all form elements!
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3. Specify the page or script that will process the form data. 

In the Document window, click the form outline to select the form. In the Property inspector (Window > Properties), type the path in the Property inspector’s Action text box, or click the folder icon to navigate to the appropriate page or script.

4. Specify the method to use to transmit the form data to the server. 

In the Property inspector, select one of the following options in the Method pop-up menu:

Default uses the browser’s default setting to send the form data to the server. Typically the default is the GET method.[image: image4.png]¥ Properties
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GET appends the value to the URL requesting the page.v

POST embeds the form data in the HTTP request.

5. Insert form objects. 

Place the insertion point where you want the form object to appear in the form, and then select the object in the Insert > Form menu, or in the Forms category of the Insert bar.
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For more information, see Inserting HTML form objects or Inserting dynamic HTML form objects.

If desired, set the properties of the form object after inserting it in the page. For more information, select the form object and click the Help icon in the Property inspector.
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Automating tasks.

Buttons Perform actions when clicked. You can add a custom name o label for a button, or use one of the predefined "Submit”
or "Reset” labels. Use a button to submit form data to the server or to reset the form. Yol can also assign other processing tasks
that you define in a script. For example, the button might calculate the total cost of items selected based on assigned values.

Check boxes Allow multiple responses within a single group of options. A user can select as many options as apply. The,
following examle shows three check box items selected: Surfing, Mountain Biking, and Rafting.
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option. If the user dlicks Surfing, the Rafting button is automatically cleared.
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want, including invalid data, you set the exact values returned by a menu.

Note: 4 pop-up menu on an HTML form is not the same as a graphical pop-up menu. For information on creating, editing, and
showing and hiding a graphical pop-up menu, see the link at the end of this section.
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6. Adjust the layout of the form as desired. 

You can use line breaks, paragraph breaks, preformatted text, or tables to format your forms. You cannot insert a form in another form (that is, you cannot overlap tags), but you can include more than one form in a page.

When designing forms, remember to label the form fields with descriptive text to let users know what they’re responding to--for example, "Type your name" to request name information.

Use tables to provide structure for form objects and field labels. When using tables in forms make sure all the table tags are included between the form tags.

Form objects
In Dreamweaver, form input types are called form objects. Form objects are the mechanisms that allow users to input data. You can add the following form objects to a form: 
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To insert a dynamic HTML form menu:
L. Click inside the HTHL form on your page,
2. Select Insert > Farm > List/Menu,
Dreamweaver inserts a List/Menu form object into the page
3. Select the List/Menu form object.
The Property inspector displays the List/Menu properties.
4. In the Property inspector, dlick the Dynamic button to display the Dynamic List/Menu dialog box

mic List/Menu

Men:

Stat Optons:

Opions Fon Recordse
Vaes:

Label:

Select Vakie Equal To: |

5. Complete the dialog box and dlick 0K
For more information, see Setting the Dynamic List/Henu dislog box options.

Related topics
© Making existing HTML form menus dynamic

View comments on LiveDocs
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Text fields accept any type of alphanumeric text entry. The text can be displayed as a single line, 
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multiple lines, and as a 

password field where entered text is replaced by asterisks or bullets to hide the text from onlookers.

	NOTE
	 
	Passwords and other information sent to a server using a password field are not encrypted. The transferred data can be intercepted and read as alphanumeric text. For this reason, you should always provide encryption for data you want to keep secure.


Hidden fields store information entered by a user, such as a name, e-mail address, or viewing preference, and then use that data when the user next visits the site. 

Buttons perform actions when clicked. Typically these actions include submitting or resetting a form. You can add a custom name or label for a button, or use one of the predefined "Submit" or "Reset" labels.

Checkboxes allow multiple responses within a single group of options. A user can select as many options as apply. The example below illustrates this by showing three checkbox items selected: Surfing, Mountain Biking, and Rafting.
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Radio buttons represent exclusive choices. Selecting a button within a radio button group deselects all others in the group (a group consists of two or more buttons that share the same name). In the example below, Rafting is the currently selected option. If the user clicks Surfing, the Rafting button is automatically cleared.
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List menus display option values within a scrolling list that allows users to select multiple options. The Menu option displays the option values in a menu that allows users to select only a single item.

	NOTE
	 
	A pop-up menu on an HTML form is not the same as a graphical pop-up menu. For information on creating, editing, and showing and hiding a graphical pop-up menu, see Show Pop-Up Menu.


Jump menus are navigational lists or pop-up menus that let you insert a menu in which each option links to a document or file.

File fields let users browse to a file on their computer and upload the file as form data. 

Image fields let you insert an image in a form. Image fields can be used to make graphical buttons such as Submit or Reset buttons.

Creating a dynamic HTML form menu

You can dynamically populate an HTML form menu or list menu with entries from a database.

For most pages, you can use an HTML menu object. For ASP.NET pages, you must use a DropDownList or ListBox form control. For more information, see Building ASP.NET forms.

Before you begin, you must insert an HTML form in a ColdFusion, PHP, ASP, or JSP page, and you must define a recordset or other source of dynamic content for the menu. For more information, see Defining a recordset.
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To insert a dynamic HTML form menu:

1. Click inside the HTML form on your page. 

2. Select Insert > Form > List/Menu. 

Dreamweaver inserts a List/Menu form object into the page.
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3. Select the List/Menu form object. 

The Property inspector displays the List/Menu properties.

4. In the Property inspector, click the Dynamic button to display the Dynamic List/Menu dialog box. 

5. Complete the dialog box and click OK. 

Setting the Dynamic List/Menu dialog box options

The Dynamic List/Menu dialog box lets you a populate a list/menu form object with content from a database or other content source.

To set the dialog box options:

1. In the Menu pop-up menu, select the list/menu form object you want to make dynamic. 

2. In the options From Recordset pop-up menu, select the recordset you want to use as a content source. This menu also allows you to later edit both static and dynamic list/menu items. 

3. The Static Options area lets you enter a default item in the list or menu. This portion of the dialog box also allows you to edit static entries in a list/menu form object after adding dynamic content. 

Use the Plus (+) and Minus (–) buttons to add and remove items in the list. Items are in the same order as in the Initial List Values dialog box. The first item on the list is the selected item when the page is loaded in a browser. Use the up and down arrow buttons to rearrange items in the list.

4. In the Values pop-up menu, select the field containing the values of the menu items. 

5. In the Labels pop-up menu, select the field containing the labels for the menu items. 

6. If you want a particular menu item to be selected when the page opens in a browser or when a record is displayed in the form, enter a value equal to the menu item’s value in the Select Value Equal To box. 

You can enter a static value or you can specify a dynamic one by clicking the lightning bolt icon beside the box and selecting a dynamic value from the list of data sources. In either case, the value you specify should match one of the menu item values.

7. Click OK. 

8. Test and save

Create the form in Dreamweaver using the Window->Insert->form menu item. Add the input elements like multiline text box, text field, and other elements in the form as well. Once you have created the form, it is now time to include the validation with Spry.
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How to Use the Dreamweaver Form Validation Feature

Form Handling, Form Validation 

dreamweaver form validation, Form Validation, javascript form validation 
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Sometimes, you may feel frustrated when you look at the form submissions that you get from a web form and find out that the respondents did not fill in some crucial details. This calls for some details on the form to become mandatory to fill in. for example, a form that is used to subscribe visitors to regular newsletters via email will be of no use if the user does not enter their email address. In case you are shipping products to the user, it will be necessary that you make sure that they enter their address on the form.

In this article, we will see some of the built-in validations supported by DreamWeaver. The advantage is that you can add those validations right from DreamWeaver. These are known as Spry validation widgets. With Spry validation widgets, you can verify the input in a text field, a check box, a text area, a group of radio buttons and even a pull-down(drop-down) menu. You are also able to limit the input to specific information type such as date/time, phone numbers, email addresses or even the length of input inside a text box. 

Note: If you have not used the Javascript form validation script here, you may want to check it out. It is quite easy to do form validations using that script. 

The process is quite simple which we will see it in the following steps.

1. Create the form

Create the form in Dreamweaver using the Window->Insert->form menu item. Add the input elements like multiline text box, text field, and other elements in the form as well. Once you have created the form, it is now time to include the validation with Spry.
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2. Insert Spry Validation

Select the form element then click on the appropriate Spry form button on the Insert panel. In order to add validation to a group of radio buttons, you need to create them as part of the Spry Validation Group Widget. Dreamweaver will add the code to validate the entries in the fields. The Spry widget will add some JavaScript code in order to validate information entered into the fields and CSS in order to customize the look of the error messages and the entry fields.



A pop up window will also appear informing you that CSS and JavaScript files have been added to the root folder of your site.



3. Select the validation type

The most basic type of validation makes sure that something has been typed into a field and it is not left blank or unselected. However, there are additional validation options for every field in the form.
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4. The trigger for the validation

In most cases, the validation is triggered when the submit button is clicked. However, this may be too late in long forms. With the Spry widget, you can do the validation as soon as the user enters data into the form fields giving instant feedback.

For example, when the user enters their email address in the incorrect format and moves on to the next field, you can notify them immediately.
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5. Customize the error message

When your visitors leave blank fields inside the form or enters incorrect data, you need to inform them about what went wrong and how it can be fixed. For example, leaving a text field entry blank may bring up an error like “A value is required”. However, this is not helpful enough to the user. These error messages can be changed in Design view by selecting the error message text and typing in the new error message. For example the “Invalid Format” error message can be changed to read something like “Please enter a valid email address like someone@gmail.com”.
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<script type=rtext/javascriptt>

var sprytextfieldl = new Spry.Widget.ValidationTextField ("spryFirstName|
script:





Create Your "Mailto" Form 
1. Switch to the Forms tab on the Insert bar, and click on Forms. You'll now see a dropdown list of form elements you can add.

2. To set the form properties, click on the Form box. In the Properties menu, enter the following:

Action: mailto:thetargetemailaddress@something.com

Method: GET

Enctype: text/plain
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3. Choose the fields you want from the Form tab on the Insert bar.
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4. To add the submit button, click the Button icon and set the action to Submit Form.
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5. Save the file.
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Add text fields
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Add more text fields

Then add a Text Area
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Change the area to suit make lines 12 and character width 50

Insert some  buttons
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Insert Reset Button
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Change the value to Reset
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Insert  Yes or No Start with the Yes button and make it checked

[image: image31.png]‘Submit (Submit ) Reset (Reset) Did you like the show ¥/ Yes 0 No

S ‘ Checked vaue [fed ) i sate @ Checked s (e 18)

Ves O Unchecked





Add a no button
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Add a Radio Button
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Add a list menu
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Enter List Values
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6. Upload the file to your web server and test it.

Tips 
· Setting the encoding type to 

text/plain

 is crucial; otherwise, you’ll get strange results.

· Remember that the proper functioning of "mailto" forms depends upon the web browsers, email clients and operating systems your site visitors use. They don’t always work. Test with a variety of combinations whenever possible.

</script>
</head>
<body text="#000000" bgcolor="#FFFFFF" link="#0000FF" vlink="#551A8B" alink="#0000FF">
<form method=POST action="http://peterfaulks.net/cgi-bin/formmail.pl" name="TEST Application">
  <input type=hidden name="recipient" value="peterfaulks@westnet.com.au" /><input type=hidden name="subject" value="Test Application Form" />
<center>
<h1>
<img SRC="Header7.jpg" ALT="Great Golfing Holidays" height=138 width=356 /></h1></center>

<center>
Terminology

Before we begin creating our tables, there is some basic terminology you will need to know.
Input - allows you to input data into your HTML document. There are many different types of input.

We will examine 5 here, so that you know and understand the differences between them. We will only really be working with two of them, the radio and the text.

TYPE = Radio- Radio buttons allow the users of your form to select only 1 response for a multiple choice question.  

TYPE = Checkbox- Check boxes allow the users of your form to select multiple answers to a single question.

TYPE = Selection List- create a (selection) list of possible responses to a question. These are the type of input where there is a response shown, and a drop-down list for the user to select.

TYPE = Text- Text boxes enable the user to enter a single line of text.  An example would be asking a person to enter his or her name or address.

TYPE = Textarea- TEXTAREA boxes are similar to TEXT boxes, except they allow the user to enter multiple lines of text.  An example where TEXTAREA boxes are used is in the comment section of a form.  

TYPE = Button- Creates a button. Types of buttons include submit, reset, or just button.

VALUE - the value of the response chosen by the user. In other words, the users response to your question.
NAME - is the name of the question or the name of the input.
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JAVASCRIPT IS CASE SENSITIVE. That means that a word like Donna is different than donna or DONNA. Be careful here and minimize the number of times you use capital letters. That will make things easier for you.



Inserting a Form Into Your Document

To insert a form into your document, from the menu bar, select INSERT >> FORM. There will be a red-dashed, retangular box on your screen. We will be typing the contents of the form into this box. Notice the change in the selection properties box.

See the image below.
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Inserting Text Into a Form

The first thing we will want our form to do is ask the user for his/her name. To create this form, make sure your cursor is inside the red-dashed box. First, type something like "Please Enter Your Name: "

Then from the menu bar, select INSERT >> FORM OBJECT >> TEXT. 

The selection properties box should resemble the image below.
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You will also notice a long rectangular box next to your text. This is called a text field. 

The box under the words TextField in the left part of the selection properties box is where we will name this input. Naming the input is important because our JavaScript will require the name of the input to process the input. Call the input "input1". Since some students may have long names, let's make the length of the box 50 characters. 

To do this, in the box labeled Char Width, type 50. Your selection properties box should now look like the one below.
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Top of Form

Bottom of Form

Top of Form

Please Enter Your Name: MACROBUTTON HTMLDirect 
  

Bottom of Form



Inserting Radio Buttons into Your Form

To ask the multiple choice question, we will want to use radio buttons as our method of input. 
Because of the way the JavaScript is written, we will be putting each question into a different form. 

Step 1: From the menu bar, select INSERT >> FORM.
Step 2: Type in your question. I'd suggest numbering your questions to make them easier to read. For example: 1. What is the newest color M&M?
Step 3: From the menu bar, select INSERT >> FORM TYPE. Select Radio as your option. The selection properties box should resemble the one below. You can leave the name of the input as radiobutton if want. Leave the Initial State as Unchecked. Checked would mean that the answer was automatically pre-selected.
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Top of Form

1. What is the newest color M&M?
MACROBUTTON HTMLDirect 
  Yellow 

Bottom of Form

Step 4: Add three more radio buttons and three more responses. When finished, your first question should resemble the form below.

Top of Form

1. What is the newest color M&M?
MACROBUTTON HTMLDirect 
  Yellow
MACROBUTTON HTMLDirect 
  Green
MACROBUTTON HTMLDirect 
  Red
MACROBUTTON HTMLDirect 
  Blue 

Bottom of Form


Repeat the steps above for the other 3 questions of your quiz. When done, save the file to your disk. We will be using this file again when we create the JavaScript to grade the quizzes. 



Buttons

In order for our form to either be sent to our JavaScript, we need to have some way of sending the information. This is the purpose of a button.
Step 1: Insert a new form into your webpage.
Step 2: From the menu bar, select INSERT >> FORM OBJECTS >> BUTTON.

Your selection properties box will resemble the one below.

[image: image47.png]Butontiame

[

Label [submic

Aoton @ gubmitform

© esattom

© pe

GO





Step 3: Under Action, select None. Notice your button will now say "Button" instead of Submit.

Step 4: Under Label, type something like Ready To Be Graded.

Step 5: Click on the little pencil on the very right part of the selection properties box, directly under the ?. This is the EDIT box. You will be presented with the box below. Type in the following. onclick="first()" Include the double quotes when you edit the input tag. This is what will call the JavaScript function we will be writing in the next lecture.
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When you are done, you should have a button like the one below.

Top of Form

Bottom of Form

Top of Form

Bottom of Form

 



Assignment 1: Create your own 4 question self-grading multiple choice quiz. If you are creating a mathematical quiz that involves fractions, formula's or anything that requires the questions or answers to be images, use Snag-It to create an gif or jpg file for each statement. Then just input the image instead of typing the question or answer.

Assignment 2: Create your own 4 question self-grading fill-in-the-blank style quiz. The assignment is basically the same as the one above, except your input fields will be of type text instead of radio. To see a sample quiz, go to the fill-in quiz I have at the website.
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For submit use the Submit Value
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